Sympton:

"Add-ins are currently blocked to help protect the security of your computer. Click 'See Details' to learn how to fix this issue."


Cause:

Internet Explorer zones are not set to "Enable Protected Mode".


Resolution:

1. In Internet Explorer, click the Tools button, and then click Internet Options.

2. Click the Security tab, and then select the Internet Sites Zone.

3. Select the Enable Protected Mode check box, and then click OK.

4. Restart Internet Explorer and Outlook. Now before you tell me you don't use IE, fire up Outlook, then look in Task Manager. Kill IE from there.

5. Try now

6. If it didn't work, enable Protected mode on Restricted Zone and try.


Source:

https://community.spiceworks.com/topic/2105539-outlook-2016-add-ins-from-store-not-working


Disclaimer
This information is intended for general information purposes only and to assist customers in understanding system functionality. It should not be construed as legal advice or opinion on any specific facts or circumstances. You are advised to consult your own compliance staff or attorney regarding your specific questions or situation to ensure your compliance with company policies & procedures, applicable laws, and regulations.